WeCreativez WhatsApp Support
Klopsoft Websites helpt u graag met uw vragen m.b.t. uw website, vindbaarheid of andere internet marketing gerelateerde onderwerpen
Problemen met de update WordPress 5.5 verhelpen
Klopsoft Websites / WordPress / Problemen met de update WordPress 5.5 verhelpen

U merkt niet altijd direct of er problemen zijn na het updaten van WordPress. Hier komt u vaak pas later tegen als u iets aan uw website wilt toevoegen of bewerken. In de laatste update van WordPress 5.5. is jQuery Migrate uitgeschakeld. jQuery Migrate is een tool die WordPress al jaren gebruikt om plug-ins en thema’s met verouderde code nog steeds correct te laten werken. Door jQuery Migrate uit te schakelen, werken veel verouderde plug-ins en thema’s niet meer correct. Dit kan resulteren in niet correct werkende websites.

Wat is jQuery Migrate?

Het is een javascript bibiliotheek, die ontwikkelaars van thema’s en plug-ins heeft geholpen om de compatibiliteit van verouderde jQuery-code te behouden. In feite hielp jQuery Migrate oude code correct te werken op de huidige jQuery-versie en later. Query Migrate was bedoeld om ontwikkelaars tijdens de overgangsperiode te helpen bij het vervangen van hun code door modernere code (of deze volledig te verwijderen).

Nu is de vraag waarom deze tool (jQuery Migrate) uitgeschakeld heeft?

Oudere versies van jQuery worden niet langer ondersteund, dus het is noodzakelijk dat WordPress de coderingsstandaarden bijwerkt. Terwijl WordPress zich voorbereidt op de overgang naar het updaten naar de nieuwste ondersteunde versie van jQuery, was het verwijderen van jQuery Migrate een vereiste eerste stap om ervoor te zorgen dat plug-ins en thema’s up-to-date zijn en niet langer verouderde code gebruiken.

Waarom is de website stuk na deze update?
Het is feitelijk heel simpel… binnen de website wordt een plug-in of een thema gebruikt met verouderde code. Na het updaten naar WordPress 5.5. zullen deze verouderde plug-ins of thema’s niet meer correct werken. Doordat deze thema of plug-in niet meer correct werkt, kan dit de website “kapot maken”.

Hoe kunt u problemen met de update WordPress 5.5 verhelpen?

Als u problemen ervaart nadat u de update heeft geinstalleerd, dan is het raadzaam om de volgende plug-in te installeren en te activeren: jQuery Migrate Helper-plug-in
Deze plug-in zal de jQuery Migrate-tool die is verwijderd in WordPress 5.5 opnieuw inschakelen en u informatie geven over welke plug-in of welk thema de problemen zou kunnen veroorzaken. Zo kunt u proberen dit op te lossen.